<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"bed08a364b","applicationID":"16192845","transactionName":"Jg1fEkIMXl4HQU0ERRELUgpVEB1BClwV","queueTime":6,"applicationTime":101,"agent":""}</script>
<script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="canonical" href="http://www.atlasobscura.com/articles/watch-the-walls-shimmer-at-irans-emerald-mosque">
<link rel="icon" href="//assets.atlasobscura.com/assets/favicon-cc5216a130077092525c8c0c8564549de1817d1a1885e1d69369fd98aaff504a.ico">
<title>Watch the Walls Shimmer at Iran&#39;s Emerald Mosque | Atlas Obscura</title>
<meta property="description" content="Shah Cheragh is one dazzling funerary monument."/>
<script src="//maps.google.com/maps/api/js?v=3&amp;key=AIzaSyDS5K_jUTkei2yHIfiUGCoXTjyaHMO0N84&amp;libraries=places&amp;language=en"></script>
<meta property="fb:app_id" content="206394544492"/>
<meta property="fb:admins" content="599046014"/>
<meta property="fb:admins" content="784963490"/>
<meta property="fb:admins" content="514970725"/>
<meta property="fb:admins" content="2208307"/>
<meta property="fb:admins" content="743664191"/>
<meta property="og:site_name" content="Atlas Obscura"/>
<meta name="p:domain_verify" content="0f207004875a5511f774fc29f0a5a3f3"/>
<meta name="pocket-site-verification" content="8353ea6cd97e141f193687e3013ce3"/>
<link rel='alternate' type='application/rss+xml' title='Atlas Obscura - Latest Articles and Places' href='http://www.atlasobscura.com/feeds/latest'>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
    ga('create', 'UA-8347316-6', 'auto');
  ga('send', 'pageview');
</script>
 
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '1494388927542275'); // Insert your pixel ID here.
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1494388927542275&ev=PageView&noscript=1"/></noscript>
 
 
<script>
  !function(d,s,id){
    var js,fjs=d.getElementsByTagName(s)[0];
    if(!d.getElementById(id)){
      js=d.createElement(s);
      js.id=id;
      js.async=true;
      js.src="https://platform.twitter.com/widgets.js";
      fjs.parentNode.insertBefore(js,fjs);}
    }
  (document,"script","twitter-wjs");
  </script>
<script type="text/javascript">
      __reach_config = {
        pid: '55b80192736b79f8db0000ae',
        title: 'Watch the Walls Shimmer at Iran&#39;s Emerald Mosque',
        //SR will use og:url
        date: '2017-01-30 17:43:00 UTC',
        authors: [ 'Ella Morton'],
        channels: ['articles'],
        tags: ["islam", "mosques", "video wonders", "video"],
        ignore_errors: false
      };
      (function(){
        var s = document.createElement('script');
        s.async = true;
        s.type = 'text/javascript';
        s.src = document.location.protocol + '//d8rk54i4mohrb.cloudfront.net/js/reach.js';
        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(s);
      })()
    </script>
<script>
      window.AtlasObscura = {};
    </script>
<script>
    window.lazySizesConfig = window.lazySizesConfig || {};
    lazySizesConfig.lazyClass = 'lazy';
    lazySizesConfig.loadMode = 1;
    </script>
<script>
      AtlasObscura.current_article = {"id":7867,"title":"Watch the Walls Shimmer at Iran's Emerald Mosque","associated_places":[]};
    </script>
<script type="text/javascript">
      function isSmallScreen () {
        return window.innerWidth < 668;
      }
    </script>
<script src="//assets.atlasobscura.com/assets/application-c2e952a396c1d0ff3c53249d67b51c8fe19658b430721184ab92fcb0d1744d79.js"></script>
<style type="text/css">.lazy,.lazyloading{background-image:asset-url("icons/ao.svg");}</style>
<link rel="stylesheet" media="screen" href="//assets.atlasobscura.com/assets/application-bfa087a0a60e8b91809b8261cfac5e6ea44efa8f9b2f244efe93fedf0c138a69.css"/>
<script type='text/javascript'>
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
        var gads = document.createElement('script');
        gads.async = true;
        gads.type = 'text/javascript';
        var useSSL = 'https:' == document.location.protocol;
        gads.src = (useSSL ? 'https:' : 'http:') +
          '//www.googletagservices.com/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
      })();
    </script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineOutOfPageSlot('/9729793/1x1_tracking_pixel', 'div-gpt-ad-1438011102027-12')
    .addService(googletag.pubads());



      var avoidSiderailAd = ( !isSmallScreen() && false );
      if ( !avoidSiderailAd ) {
        var btfSize = googletag.sizeMapping()
          //in a sizeMapping, [0,0] denotes the fallback.It matches any size
          .addSize([0, 0], [300, 250])
          //[668,0] is a min width of 668px
          //permitted sizes are in order of precedence
          .addSize([668, 0], [[300, 600], [300, 250]])
          .build();

        googletag.defineSlot('/9729793/300x250_300x600_box_btf', [[300, 600], [300, 250]], 'div-gpt-ad-1438011102027-1')
        .defineSizeMapping(btfSize)
        .addService(googletag.pubads());
      }

      var avoidSecondarySlot = ( !isSmallScreen() || isHomePage() );
      if ( !avoidSecondarySlot ) {
        var btfSecondarySize = googletag.sizeMapping()
          .addSize([0, 0], [300, 250])
          .addSize([668, 0], [])
          .build();

        googletag.defineSlot('/9729793/300x250_300x600_secondary', [[300, 250], [300, 600]], 'div-gpt-ad-1438011102027-11')
          .defineSizeMapping(btfSecondarySize)
          .setCollapseEmptyDiv(true)
          .addService(googletag.pubads());
      }

      var leadboardSize = googletag.sizeMapping()
        .addSize([0, 0], [])
        .addSize([668, 0], [[728, 90], [970, 250]])
        .build();

      googletag.defineSlot('/9729793/970x250_728x90_below_nav', [[728, 90], [970, 250]], 'div-gpt-ad-1438011102027-10')
      .defineSizeMapping(leadboardSize)
      .addService(googletag.pubads());

      var colSize = googletag.sizeMapping()
        .addSize([0, 0], [[1,1], [300, 400]])
        .addSize([668, 0], [[1,1], [535, 400]]);

      googletag.defineSlot('/9729793/1x1_video_btf', [[1, 1],[300, 400], [535, 400]], 'div-gpt-ad-1438011102027-9')
        .defineSizeMapping(colSize)
        .setCollapseEmptyDiv(true)
        .addService(googletag.pubads());
        googletag.pubads().addEventListener('slotRenderEnded', function(e){
          //this will add a background to all 400 height ads...should be desireable
          if(e.size[1]===400) {
            $('#div-gpt-ad-1438011102027-9').addClass('ad-background');
          };
        })


    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script type="text/javascript">
  googletag.cmd.push(function() {
    googletag.pubads().setTargeting("page", "article")
      .setTargeting("pid", "article-7867")
      .setTargeting("tags", ["islam", "mosques", "video wonders", "video"]);
  });
</script>
<script type="text/javascript">
      googletag.cmd.push(function() {
        googletag.pubads().setTargeting("environment", "production");
      });
    </script>
<meta property="og:title" content="Watch the Walls Shimmer at Iran's Emerald Mosque"/>
<meta property="og:url" content="http://www.atlasobscura.com/articles/watch-the-walls-shimmer-at-irans-emerald-mosque"/>
<meta property="og:image" content="https://assets.atlasobscura.com/media/W1siZiIsInVwbG9hZHMvYXNzZXRzLzI5MDFjZmViMDBjZDcwMzZiNl9zaGFoLmpwZWciXSxbInAiLCJjb252ZXJ0IiwiLXF1YWxpdHkgOTEgLWF1dG8tb3JpZW50Il0sWyJwIiwidGh1bWIiLCI2MDB4PiJdXQ/shah.jpeg"/>
<meta property="og:description" content="Shah Cheragh is one dazzling funerary monument."/>
<meta property="og:type" content="article"/>
<meta property="article:published_time" content="2017-01-30 12:43:00 -0500"/>
<meta property="article:modified_time" content="2017-01-30 12:46:26 -0500"/>
<meta property="article:tag" content="islam"/>
<meta property="article:tag" content="mosques"/>
<meta property="article:tag" content="video wonders"/>
<meta property="article:tag" content="video"/>
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@atlasobscura">
<meta name="twitter:image" content="https://assets.atlasobscura.com/media/W1siZiIsInVwbG9hZHMvYXNzZXRzLzI5MDFjZmViMDBjZDcwMzZiNl9zaGFoLmpwZWciXSxbInAiLCJjb252ZXJ0IiwiLXF1YWxpdHkgOTEgLWF1dG8tb3JpZW50Il0sWyJwIiwidGh1bWIiLCI2MDB4PiJdXQ/shah.jpeg">
<script type="text/javascript">
      /* Version: 0.7 */
      /* <![CDATA[ */
      try {
      var _mag = _mag || {};
      _mag.kw = "islam,mosques,video wonders,video";
      _mag.kw_encoded = 0;
      _mag.shortName = 'atlasobscura-travel';
      _mag.default_protocol = ('https:' == document.location.protocol ? 'https:' : 'http:');
      _mag.startTime = (new Date()).getTime();
      (function(d,t) {
      var mag = d.createElement('script'); mag.type = 'text/javascript'; mag.async = true; mag.src = t;
      var head = d.getElementsByTagName('head')[0] || d.documentElement; head.insertBefore(mag, head.firstChild);
      })(document,  _mag.default_protocol + '//d3ezl4ajpp2zy8.cloudfront.net/atlasobscura-travel_tag.js');
      } catch (e) {}
      /* ]]> */
    </script>
<link rel="amphtml" href="http://www.atlasobscura.com/articles/watch-the-walls-shimmer-at-irans-emerald-mosque.amp"/>
</head>
<body class="articles" name>
<a class="site-top-notification-link" href="/book">
<div class="site-top-notification-container container-fluid">
<div class="copy-container container">
<h6>Order our new book, <em>Atlas Obscura: An Explorer&rsquo;s Guide to the World&rsquo;s Hidden Wonders</em></h6>
<div class="site-top-notification-image">
<img class="top-book-img" src="//assets.atlasobscura.com/assets/book/mini_book-8620cc981e76c808478a51355a637327e7d6be0aee9847ccafab48ccfe007a0f.jpg" alt="Mini book"/>
</div>
</div>
<div class="js-top-notification-dismiss-link dismiss-link">
<span class="icon-menu-close"></span>
</div>
</div>
</a>
<div id="fb-root"></div>
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '206394544492',
      xfbml      : true,
      version    : 'v2.5'
    });
    FB.Event.subscribe('edge.create', function(response) {
      Cookies.set('fb_subscriber', '1', { expires: 200, path: '/' });
    });
    FB.Event.subscribe('edge.remove', function(response) {
      Cookies.set('fb_subscriber', '0', { expires: 200, path: '/' });
    });
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<header class="page-header">
<div class="container js-page-left-reference">
<nav class="navbar-main">
<div class="nav-header">
<div class="row">
<a class="logo-link col-md-3" title="Atlas Obscura" href="/">
<i class="icon-atlas-icon js-masthead-logo"></i>
<i class="icon-atlas-logo"></i>
</a>
<div class="hidden-xs hidden-sm nav-tools-right with-notification-spacer hide-spacer js-notification-spaceable">
<ul id="nav-social-list">
<li><a href="https://www.facebook.com/atlasobscura/" class="icon-facebook btn-icon nav-social-btn js-social-action-tracked" id="nav-soc-btn-facebook" data-position="Header" data-service="Facebook" data-action="Like" target="_blank"></a></li>
<li><a href="https://twitter.com/atlasobscura" class="icon-twitter btn-icon nav-social-btn js-social-action-tracked" id="nav-soc-btn-twitter" target="_blank" data-position="Header" data-service="Twitter" data-action="Follow"></a></li>
<li><a href="https://www.instagram.com/atlasobscura/" class="icon-instagram btn-icon nav-social-btn js-social-action-tracked" data-position="Header" data-service="Instagram" data-action="Follow" id="nav-soc-btn-instagram" target="_blank"></a></li>
<li><a href="https://www.pinterest.com/atlasobscura/" class="icon-pinterest btn-icon nav-social-btn js-social-action-tracked" data-position="Header" data-service="Pinterest" data-action="Follow" id="nav-soc-btn-pinterest" target="_blank"></a></li>
<li><a href="http://www.atlasobscura.com/feeds/latest" class="icon-rss btn-icon nav-social-btn js-social-action-tracked" data-position="Header" data-service="RSS" data-action="Follow" id="nav-soc-btn-rss" target="_blank"></a></li>
</ul>
<a id="nav-sign-in-link" class="nav-session-link detail-sm" href="/sign-in">Sign In</a>
<i class="or-pipe or-pipe-sessions"></i>
<a id="nav-sign-up-link" class="nav-session-link detail-sm" href="/join">Join</a>
</div>
<i class="icon-menu-open nav-toggle js-nav-toggle visible-xs visible-sm"></i>
</div>
</div>
<div class="nav-content js-nav-content is-slider-hidden-m">
<form class="js-search-form-ui nav-search-m" action="search" accept-charset="UTF-8" method="post"><input name="utf8" type="hidden" value="&#x2713;"/><input type="hidden" name="authenticity_token" value="Q9OMgiC3fgZoBsdw7ARaNdAGhhK1qrXlsWJv8sK1bhOhyqzSqutiW+EdotJf6Rxbux6SVgvJ9SSgeqPxS7TbAA=="/>
<div class="search-group search-group-m">
<label class="heading-sm" for="query">Find</label>
<input type="text" name="query" id="query" placeholder="e.g. &#39;ruins&#39; or &#39;ghost towns&#39;" class="js-search-query-ui"/>
</div>
<div class="search-group search-group-m">
<label class="heading-sm" for="location">Near</label>
<input type="text" name="location" id="location" placeholder="e.g. &#39;Brooklyn&#39;" class="search-location-m js-search-location-ui"/>
<button name="button" type="submit" class="icon-btn btn-submit">
<i class="icon-search"></i>
</button> </div>
</form>
<ul class="nav-verticals">
<li class="nav-vertical js-taphover nav-atlas">
<a class="heading-sm nav-link" href="/places">The Atlas</a>
<div class="nav-dropdown">
<div class="container nav-dropdown-content">
<div class="fake-bg"></div>
<div class="row table-display">
<div class="col-md-3 left-panel">
<ul class="nav-links-column links-column">
<li>
<a class="tab selected" data-target="destinations-panel" href="">
Top Destinations<span class="icon-arrow-down nav-arrow-right"></span>
</a>
</li>
<li>
<a class="tab" data-target="recent-places-panel" href="">
Newly Added Places<span class="icon-arrow-down nav-arrow-right"></span>
</a>
</li>
<li>
<a href="/places?sort=likes_count">
Most Popular Places
</a>
</li>
<li>
<a href="/random">
Random Place
</a>
</li>
<li>
<a href="/lists">
Lists
</a>
</li>
<hr>
<li>
<a class="add-place js-user-required" href=/places/new>
<i class="icon-add-place"></i>
Add a Place
</a>
</li>
</ul>
</div>
<div id="recent-places-panel" class="col-md-9 right-panel" style="display:none">
<h2 class="nav-category-heading heading-md-non-uppercase">Newly Added Places</h2>
<div class="row">
<a class="col-md-3 nav-card" href="/places/lanai-cat-sanctuary">
<img data-src="//assets.atlasobscura.com/media/W1siZiIsInVwbG9hZHMvcGxhY2VfaW1hZ2VzL2QzMTJmOWZhMGY5ODNiYjYwZV9JTUdfMDkzOS5qcGciXSxbInAiLCJjb252ZXJ0IiwiLXF1YWxpdHkgOTEgLWF1dG8tb3JpZW50Il0sWyJwIiwidGh1bWIiLCIyMjJ4MTQ4IyJdXQ/IMG_0939.jpg" title="Lanai Cat Sanctuary" alt="Lanai Cat Sanctuary" data-width="638" data-height="625" class="lazy img-responsive" nopin="nopin" src="//assets.atlasobscura.com/assets/blank-11b9c95a68e295dddd0ea924647536578ce285b2c8469a223c01df1ff3166af1.png"/>
<div class="detail-sm nav-card-location">Lanai City, Hawaii</div>
<h3 class="title-sm nav-card-title"><span class="title-underline">Lanai Cat Sanctuary </span></h3>
<div class="lat-lng nav-card-details">
20.7649, -156.9345
</div>
</a> <a class="col-md-3 nav-card" href="/places/comfort-maple-canadas-oldest-maple-tree">
<img data-src="//assets.atlasobscura.com/media/W1siZiIsInVwbG9hZHMvcGxhY2VfaW1hZ2VzLzIxZWMzMGNkOWM0OTZkN2JiOV9Db21mb3J0X01hcGxlLmpwZyJdLFsicCIsImNvbnZlcnQiLCItcXVhbGl0eSA5MSAtYXV0by1vcmllbnQiXSxbInAiLCJ0aHVtYiIsIjIyMngxNDgjIl1d/Comfort_Maple.jpg" title="The Comfort Maple with red autumn foliage." alt="The Comfort Maple with red autumn foliage." data-width="980" data-height="657" class="lazy img-responsive" nopin="nopin" src="//assets.atlasobscura.com/assets/blank-11b9c95a68e295dddd0ea924647536578ce285b2c8469a223c01df1ff3166af1.png"/>
<div class="detail-sm nav-card-location">Pelham, Canada</div>
<h3 class="title-sm nav-card-title"><span class="title-underline">Comfort Maple</span></h3>
<div class="lat-lng nav-card-details">
43.0591, -79.3456
</div>
</a> <a class="col-md-3 nav-card" href="/places/giant-luecke-signature">
<img data-src="//assets.atlasobscura.com/media/W1siZiIsInVwbG9hZHMvcGxhY2VfaW1hZ2VzL2MxYWZiY2JlNTgzZDk2N2EwNV9TY3JlZW4gU2hvdCAyMDE3LTAxLTI4IGF0IDYuMTguNDMgUE0ucG5nIl0sWyJwIiwiY29udmVydCIsIi1xdWFsaXR5IDkxIC1hdXRvLW9yaWVudCJdLFsicCIsInRodW1iIiwiMjIyeDE0OCMiXV0/Screen%20Shot%202017-01-28%20at%206.18.43%20PM.png" title="Luecke from satellite view" alt="Luecke from satellite view" data-width="1504" data-height="1138" class="lazy img-responsive" nopin="nopin" src="//assets.atlasobscura.com/assets/blank-11b9c95a68e295dddd0ea924647536578ce285b2c8469a223c01df1ff3166af1.png"/>
<div class="detail-sm nav-card-location">Smithville, Texas</div>
<h3 class="title-sm nav-card-title"><span class="title-underline">Giant &#39;Luecke&#39; Signature</span></h3>
<div class="lat-lng nav-card-details">
30.0828, -97.1412
</div>
</a> <a class="col-md-3 nav-card" href="/places/metolius-balancing-rocks">
<img data-src="//assets.atlasobscura.com/media/W1siZiIsInVwbG9hZHMvcGxhY2VfaW1hZ2VzL2RiZTMyYTQwODAzYjk0OTIyOF8yNTAzNzA5NTU1MV80OTkxMTZiZWVhX2suanBnIl0sWyJwIiwiY29udmVydCIsIi1xdWFsaXR5IDkxIC1hdXRvLW9yaWVudCJdLFsicCIsInRodW1iIiwiMjIyeDE0OCMiXV0/25037095551_499116beea_k.jpg" title="The balancing rocks." alt="The balancing rocks." data-width="2048" data-height="1360" class="lazy img-responsive" nopin="nopin" src="//assets.atlasobscura.com/assets/blank-11b9c95a68e295dddd0ea924647536578ce285b2c8469a223c01df1ff3166af1.png"/>
<div class="detail-sm nav-card-location">Culver, Oregon</div>
<h3 class="title-sm nav-card-title"><span class="title-underline">Metolius Balancing Rocks</span></h3>
<div class="lat-lng nav-card-details">
44.5811, -121.4123
</div>
</a> </div>
</div>
<div id="destinations-panel" class="col-md-9 right-panel">
<h2 class="nav-category-heading heading-md-non-uppercase">Top Destinations</h2>
<section class="section-top-content">
<div class="row">
<div class="col-md-3 section-top-content-col">
<div class="places-section-top-content-header">
<h4 class="section-top-content-title detail-sm">Countries</h4>
</div>
<ul id="top-destinations-list-nav" class="top-content-list links-column top-content-list-col-sm-2">
<li>
<a href='/things-to-do/australia' title='Australia'>Australia</a>
</li>
<li>
<a href='/things-to-do/canada' title='Canada'>Canada</a>
</li>
<li>
<a href='/things-to-do/china' title='China'>China</a>
</li>
<li>
<a href='/things-to-do/france' title='France'>France</a>
</li>
<li>
<a href='/things-to-do/germany' title='Germany'>Germany</a>
</li>
<li>
<a href='/things-to-do/india' title='India'>India</a>
</li>
<li>
<a href='/things-to-do/italy' title='Italy'>Italy</a>
</li>
<li>
<a href='/things-to-do/japan' title='Japan'>Japan</a>
</li>
</ul>
</div>
<div class="col-md-9 section-top-content-col">
<div class="places-section-top-content-header">
<h4 class="section-top-content-title detail-sm">Cities</h4>
</div>
<ul id="top-content-city-list" class="top-content-list links-column top-content-list-col-sm-2">
<li>
<a href='/things-to-do/amsterdam-netherlands' title='Amsterdam'>Amsterdam</a>
</li>
<li>
<a href='/things-to-do/barcelona-spain' title='Barcelona'>Barcelona</a>
</li>
<li>
<a href='/things-to-do/beijing-china' title='Beijing'>Beijing</a>
</li>
<li>
<a href='/things-to-do/berlin-germany' title='Berlin'>Berlin</a>
</li>
<li>
<a href='/things-to-do/boston-massachusetts' title='Boston'>Boston</a>
</li>
<li>
<a href='/things-to-do/budapest-hungary' title='Budapest'>Budapest</a>
</li>
<li>
<a href='/things-to-do/chicago-illinois' title='Chicago'>Chicago</a>
</li>
<li>
<a href='/things-to-do/london-england' title='London'>London</a>
</li>
<li>
<a href='/things-to-do/los-angeles-california' title='Los Angeles'>Los Angeles</a>
</li>
<li>
<a href='/things-to-do/mexico-city-mexico' title='Mexico City'>Mexico City</a>
</li>
<li>
<a href='/things-to-do/montreal-quebec' title='Montreal'>Montreal</a>
</li>
<li>
<a href='/things-to-do/moscow-russia' title='Moscow'>Moscow</a>
</li>
<li>
<a href='/things-to-do/new-orleans-louisiana' title='New Orleans'>New Orleans</a>
</li>
<li>
<a href='/things-to-do/new-york' title='New York'>New York</a>
</li>
<li>
<a href='/things-to-do/paris-france' title='Paris'>Paris</a>
</li>
<li>
<a href='/things-to-do/philadelphia-pennsylvania' title='Philadelphia'>Philadelphia</a>
</li>
<li>
<a href='/things-to-do/prague-czech-republic' title='Prague'>Prague</a>
</li>
<li>
<a href='/things-to-do/rome-italy' title='Rome'>Rome</a>
</li>
<li>
<a href='/things-to-do/san-francisco-california' title='San Francisco'>San Francisco</a>
</li>
<li>
<a href='/things-to-do/seattle-washington' title='Seattle'>Seattle</a>
</li>
<li>
<a href='/things-to-do/stockholm-sweden' title='Stockholm'>Stockholm</a>
</li>
<li>
<a href='/things-to-do/tokyo-japan' title='Tokyo'>Tokyo</a>
</li>
<li>
<a href='/things-to-do/toronto-ontario' title='Toronto'>Toronto</a>
</li>
<li>
<a href='/things-to-do/vienna-austria' title='Vienna'>Vienna</a>
</li>
</ul>
</div>
</div>
</section>
<a class="btn btn-stretch destination-counter-callout">
<span class="destination-count-text">
SEE ALL <span class="btn-number-lg">
5463</span> DESTINATIONS IN THE ATLAS
</span>
</a>
</div>
</div>
</div>
</div>
</li>
<li class="nav-vertical js-taphover nav-articles">
<a class="heading-sm nav-link" href="/articles">Stories</a>
<div class="nav-dropdown">
<div class="container nav-dropdown-content">
<div class="fake-bg"></div>
<div class="row table-display">
<div class="col-md-3 left-panel">
<h3 class="nav-panel-title">BROWSE STORIES BY</h3>
<ul class="nav-links-column links-column">
<li><a href="/articles?sort=columns">Columns</a></li>
<li><a href="/articles?sort=features">Features</a></li>
<li><a href="/articles?sort=interactive">Interactive</a></li>
<li><a href="/articles?sort=news">News</a></li>
<li><a href="/articles?sort=video">Video</a></li>
<li><a href="/articles?sort=visual">Visual</a></li>
</ul>
<hr>
</div>
<div class="col-md-9 right-panel">
<h2 class="nav-category-heading heading-md-non-uppercase">Most Recent Stories</h2>
<div class="row">
<a class="col-md-3 nav-card" href="/articles/couple-accused-of-using-a-massive-manure-pile-to-annoy-their-neighbors-during-a-long-feud">
<img data-src="//assets.atlasobscura.com/media/W1siZiIsInVwbG9hZHMvYXNzZXRzL2U4ZjE3ZGE4MDc3NDNjZjYyY19DM1FuTnRQV2NBRUg3M3MuanBnIl0sWyJwIiwiY29udmVydCIsIi1xdWFsaXR5IDkxIC1hdXRvLW9yaWVudCJdLFsicCIsInRodW1iIiwiMjIyeDE0OCMiXV0/C3QnNtPWcAEH73s.jpg" alt="" data-width="940" data-height="705" class="lazy img-responsive" nopin="nopin" src="//assets.atlasobscura.com/assets/blank-11b9c95a68e295dddd0ea924647536578ce285b2c8469a223c01df1ff3166af1.png"/>
<h3 class="title-sm nav-card-title"><span class="title-underline">Couple Accused of Using a Massive Manure Pile to Annoy Their Neighbors</span></h3>
<div class="detail-sm nav-card-details js-time-ago" data-timestamp="2017-01-31 14:54:00 UTC"></div>
</a> <a class="col-md-3 nav-card" href="/articles/what-happens-when-80-falcons-fly-coach">
<img data-src="//assets.atlasobscura.com/media/W1siZiIsInVwbG9hZHMvYXNzZXRzLzdhZmJlY2M1Y2M2N2E5ZGFjYV9uOWpxNWoydGF0Y3kuanBnIl0sWyJwIiwidGh1bWIiLCI3MjB4NDgwKzArMTQ1Il0sWyJwIiwiY29udmVydCIsIi1xdWFsaXR5IDkxIC1hdXRvLW9yaWVudCJdLFsicCIsInRodW1iIiwiMjIyeDE0OCMiXV0/n9jq5j2tatcy.jpg" title="Falcons on a plane." alt="Falcons on a plane." data-width="720" data-height="720" class="lazy img-responsive" nopin="nopin" src="//assets.atlasobscura.com/assets/blank-11b9c95a68e295dddd0ea924647536578ce285b2c8469a223c01df1ff3166af1.png"/>
<h3 class="title-sm nav-card-title"><span class="title-underline">What Happens When 80 Falcons Fly Coach</span></h3>
<div class="detail-sm nav-card-details js-time-ago" data-timestamp="2017-01-31 14:40:00 UTC"></div>
</a> <a class="col-md-3 nav-card" href="/articles/found-melted-uranium-rods-lost-at-fukushima">
<img data-src="//assets.atlasobscura.com/media/W1siZiIsInVwbG9hZHMvYXNzZXRzLzM2MWJkYTIzNzA4MTNhMWU5MF81NTI5MDM4MTM1X2YwNDUzYzdlNDlfYi5qcGciXSxbInAiLCJjb252ZXJ0IiwiLXF1YWxpdHkgOTEgLWF1dG8tb3JpZW50Il0sWyJwIiwidGh1bWIiLCIyMjJ4MTQ4IyJdXQ/5529038135_f0453c7e49_b.jpg" title="A shot of Fukushima from 2011." alt="A shot of Fukushima from 2011." data-width="932" data-height="681" class="lazy img-responsive" nopin="nopin" src="//assets.atlasobscura.com/assets/blank-11b9c95a68e295dddd0ea924647536578ce285b2c8469a223c01df1ff3166af1.png"/>
<h3 class="title-sm nav-card-title"><span class="title-underline">Found: Melted Uranium Rods, Lost at Fukushima</span></h3>
<div class="detail-sm nav-card-details js-time-ago" data-timestamp="2017-01-31 14:30:00 UTC"></div>
</a> <a class="col-md-3 nav-card" href="/articles/the-singer-who-topped-charts-by-embracing-his-stutter">
<img data-src="//assets.atlasobscura.com/media/W1siZiIsInVwbG9hZHMvYXNzZXRzLzg3MzhhOThhYmY4MjI0MWVkOF9TY3JlZW4gU2hvdCAyMDE3LTAxLTMwIGF0IDQuMzUuNDUgUE0ucG5nIl0sWyJwIiwiY29udmVydCIsIi1xdWFsaXR5IDkxIC1hdXRvLW9yaWVudCJdLFsicCIsInRodW1iIiwiMjIyeDE0OCMiXV0/Screen%20Shot%202017-01-30%20at%204.35.45%20PM.png" title="Scatman John in the music video for &quot;Scatman (Ski-Ba-Bop-Ba-Dop-Bop).&quot;" alt="Scatman John in the music video for &quot;Scatman (Ski-Ba-Bop-Ba-Dop-Bop).&quot;" data-width="1313" data-height="745" class="lazy img-responsive" nopin="nopin" src="//assets.atlasobscura.com/assets/blank-11b9c95a68e295dddd0ea924647536578ce285b2c8469a223c01df1ff3166af1.png"/>
<h3 class="title-sm nav-card-title"><span class="title-underline">The Singer Who Topped Charts by Embracing His Stutter</span></h3>
<div class="detail-sm nav-card-details js-time-ago" data-timestamp="2017-01-31 13:19:00 UTC"></div>
</a> </div>
</div>
</div>
</div>
</div>
</li>
<li class="nav-vertical js-taphover nav-events">
<a class="heading-sm nav-link" href="/events">Events</a>
<div class="nav-dropdown">
<div class="container nav-dropdown-content">
<div class="fake-bg"></div>
<div class="row table-display">
<div class="col-md-3 left-panel">
<h3 class="nav-panel-title">Quick Links</h3>
<ul class="nav-links-column links-column">
<li><a href="/events">All Events</a></li>
<li><a href="/unusual-trips">All Trips</a></li>
</ul>
<h3 class="nav-panel-title">Explore Events</h3>
<ul class="nav-links-column links-column">
<li><a href="/things-to-do/chicago-illinois#events">Chicago</a></li>
<li><a href="/things-to-do/los-angeles-california#events">Los Angeles</a></li>
<li><a href="/things-to-do/new-york#events">New York</a></li>
<li><a href="/things-to-do/philadelphia-pennsylvania#events">Philadelphia</a></li>
<li><a href="/things-to-do/san-francisco-california#events">San Francisco</a></li>
<li><a href="/things-to-do/seattle-washington#events">Seattle</a></li>
<li><a href="/things-to-do/washington-dc#events">Washington, D.C.</a></li>
</ul>
</div>
<div class="col-md-9 right-panel">
<h2 class="nav-category-heading heading-md-non-uppercase">Upcoming Events</h2>
<div class="row">
<a class="col-md-3 nav-card" href="/events/journey-into-darkness-iceland-feb-1-5-2017">
<div class="event-image-date-ko">
<img data-src="//assets.atlasobscura.com/media/W1siZiIsIjIwMTYvMDkvMTUvMjIvMTYvMzEvMmRhMjYwYTUtMGI4Mi00YjY4LWJlZDUtNmMwMWE3MmJjMjg2L05vcnRoZXJuIExpZ2h0cyAoNCkuanBnIl0sWyJwIiwiY29udmVydCIsIi1xdWFsaXR5IDkxIC1hdXRvLW9yaWVudCJdLFsicCIsInRodW1iIiwiMjIyeDE0OCMiXV0/Northern%20Lights%20%284%29.jpg" alt="" data-width="4630" data-height="3087" class="lazy img-responsive" nopin="nopin" src="//assets.atlasobscura.com/assets/blank-11b9c95a68e295dddd0ea924647536578ce285b2c8469a223c01df1ff3166af1.png"/>
<div class="event-date-ko">
<span class="title-md date-ko-month">Feb</span>
<span class="title-lg date-ko-day"> 1</span>
</div>
</div>
<div class="detail-sm nav-card-location">Reykjavik</div>
<h3 class="title-sm nav-card-title">
<span class="title-underline">Journey into Darkness: Iceland, Feb. 1-5, 2017</span>
</h3>
</a> <a class="col-md-3 nav-card" href="/events/bart-to-the-future">
<div class="event-image-date-ko">
<img data-src="//assets.atlasobscura.com/media/W1siZiIsIjIwMTcvMDEvMTYvMDAvMjkvMDkvNmQ4NDYyNmUtOTVmZC00Zjc4LTg3OGItY2FmOGQzOTBhNjU2L0JBUlQxLkpQRyJdLFsicCIsImNvbnZlcnQiLCItcXVhbGl0eSA5MSAtYXV0by1vcmllbnQiXSxbInAiLCJ0aHVtYiIsIjIyMngxNDgjIl1d/BART1.JPG" alt="" data-width="2896" data-height="1944" class="lazy img-responsive" nopin="nopin" src="//assets.atlasobscura.com/assets/blank-11b9c95a68e295dddd0ea924647536578ce285b2c8469a223c01df1ff3166af1.png"/>
<div class="event-date-ko">
<span class="title-md date-ko-month">Feb</span>
<span class="title-lg date-ko-day"> 4</span>
</div>
</div>
<div class="detail-sm nav-card-location">San Francisco</div>
<h3 class="title-sm nav-card-title">
<span class="title-underline">BART to the Future</span>
</h3>
</a> <a class="col-md-3 nav-card" href="/events/exploring-seattle-s-first-boom-and-the-party-thrown-in-its-aftermath">
<div class="event-image-date-ko">
<img data-src="//assets.atlasobscura.com/media/W1siZiIsIjIwMTYvMTIvMDgvMTYvMzgvNTUvYmM5MDM3YWUtNzE0Ny00Y2IxLWJhNjYtNzViYTZlYzQ3NTQ1L0plZmZXYXJlLmpwZyJdLFsicCIsImNvbnZlcnQiLCItcXVhbGl0eSA5MSAtYXV0by1vcmllbnQiXSxbInAiLCJ0aHVtYiIsIjIyMngxNDgjIl1d/JeffWare.jpg" title="Mt. Rainier as seen from Alaska-Yukon-Pacific Exposition, 1909 " alt="Mt. Rainier as seen from Alaska-Yukon-Pacific Exposition, 1909 " data-width="550" data-height="346" class="lazy img-responsive" nopin="nopin" src="//assets.atlasobscura.com/assets/blank-11b9c95a68e295dddd0ea924647536578ce285b2c8469a223c01df1ff3166af1.png"/>
<div class="event-date-ko">
<span class="title-md date-ko-month">Feb</span>
<span class="title-lg date-ko-day"> 4</span>
</div>
</div>
<div class="detail-sm nav-card-location">Seattle</div>
<h3 class="title-sm nav-card-title">
<span class="title-underline">Exploring Seattle’s First Boom (and the Party Thrown in its Aftermath)</span>
</h3>
</a> <a class="col-md-3 nav-card" href="/events/illuminating-art-neon">
<div class="event-image-date-ko">
<img data-src="//assets.atlasobscura.com/media/W1siZiIsIjIwMTUvMDkvMjQvMDUvMjUvNDUvMjM2LzExOTQyMDk0XzEwMjA3MzgzMTQ0NDg3MTA5XzU4MDc0NjAyNjQ1NzgwODIyODFfby5qcGciXSxbInAiLCJjb252ZXJ0IiwiLXF1YWxpdHkgOTEgLWF1dG8tb3JpZW50Il0sWyJwIiwidGh1bWIiLCIyMjJ4MTQ4IyJdXQ/11942094_10207383144487109_5807460264578082281_o.jpg" alt="" data-width="2048" data-height="1571" class="lazy img-responsive" nopin="nopin" src="//assets.atlasobscura.com/assets/blank-11b9c95a68e295dddd0ea924647536578ce285b2c8469a223c01df1ff3166af1.png"/>
<div class="event-date-ko">
<span class="title-md date-ko-month">Feb</span>
<span class="title-lg date-ko-day"> 5</span>
</div>
</div>
<div class="detail-sm nav-card-location">Van Nuys</div>
<h3 class="title-sm nav-card-title">
<span class="title-underline">Illuminating the Art of Neon</span>
</h3>
</a> </div>
</div>
</div>
</div>
</div>
</li>
<li class="nav-vertical nav-vertical-sessions-m hidden-md hidden-lg">
<div class="nav-session-links-wrap-m">
 
<a href="/sign-in" class="heading-sm nav-session-link-m">
<i class="icon-profile nav-session-icon"></i>Sign In
</a><i class="or-pipe or-pipe-sessions-m"></i>
<a href="/join" class="heading-sm nav-session-link-m">
Join
</a>
</div>
</li>
<li class="nav-vertical js-taphover nav-search">
<a class="heading-sm nav-link" href="javascript:void(0)">
<i class="icon-search"></i>Search
</a> <div class="nav-dropdown">
<div class="container">
<div class="row">
<form class="js-search-form-ui nav-search-d col-md-12" action="/search" accept-charset="UTF-8" method="get"><input name="utf8" type="hidden" value="&#x2713;"/>
<div class="search-group search-group-d">
<label class="heading-sm" for="query">Find</label>
<input type="text" name="query" id="query" placeholder="e.g. &#39;ruins&#39; or &#39;ghost towns&#39;" class="js-search-query-ui"/>
</div>
<div class="search-group search-group-d">
<label class="heading-sm" for="location">Near</label>
<input type="text" name="location" id="location" placeholder="e.g. &#39;Brooklyn&#39; or &#39;90210&#39;" class="search-location js-search-location-ui"/>
</div>
<button name="button" type="submit" class="btn btn-submit">
Search
</button></form>
<form class="js-search-form-to-submit" style="display:none;" action="/search" accept-charset="UTF-8" method="get"><input name="utf8" type="hidden" value="&#x2713;"/>
</form> </div>
</div>
</div>
</li>
<li class="nav-random-place hidden-sm hidden-xs">
<a id="nav-random-slot" href="/places/the-twelve-apostles">
<div id="nav-random-latlng" class="detail">
-38.6490, 143.0640
</div>
<div id="nav-random-title" class="detail">
The Twelve Apostles, Australia
</div>
</a> </li>
</ul>
</div>
<div id='div-gpt-ad-1438011102027-12' class="not-on-dom-wrapper" style="width:1px; height:1px;position:absolute;">
<script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1438011102027-12'); });
</script>
</div>
</nav>
<div class="m-nearby-search">
<a class="js-search-nearby btn btn-places btn-icon" href="https://www.atlasobscura.com/search/search_nearby">
<i class="icon-nearby-place"></i> What's near me?
</a> </div>
</div>
</header>
<div class="ad-background ad-background-below-nav hidden-sm hidden-xs">
 
<div id='div-gpt-ad-1438011102027-10' class='ad-wrapper' style='max-width: 970px; max-height: 250px; min-height: 90px; position: relative; z-index: 4999;'>
<script type="text/javascript">
    if (!isSmallScreen()) {
      googletag.cmd.push(function() { googletag.display('div-gpt-ad-1438011102027-10'); });
    }
  </script>
</div>
</div>
<article class="item-content js-article-content article--content ">
<div class="container">
<header class="item-header article-header ">
<div class="row">
<div class="col-md-12">
<h1 class="title-lg item-title">Watch the Walls Shimmer at Iran&#39;s Emerald Mosque</h1>
<div class="article-dek-wrap">
<h2 class="subtitle subtitle-lg item-subtitle">
Shah Cheragh is one dazzling funerary monument.
</h2>
<div class="article-byline-dateline">
<span class="article-byline">by <a href="/users/ella-morton?view=articles">Ella Morton</a></span>
<div class="detail-sm article-byline-date">January 30, 2017</div>
</div>
</div>
</div>
</div>
</header>
</div>
<div id="article-container" class="container">
<div class="row">
<div class="social-siderail-l col-md-1 ">
<div id="social-siderails-btns" class="hidden-xs hidden-sm">
<div class="item-social-rail-stack social-siderail-btns">
<a href="" class="icon-facebook btn-icon social-siderail-btn siderail-btn-facebook js-share-button-facebook js-social-action-tracked" data-position="Leftrail" data-service="Facebook" data-action="Share"></a>
<div class="js-facebook-count detail-sm social-siderail-count hidden-sm hidden-xs"></div>
<div class="icon-pinterest btn-icon social-siderail-btn siderail-btn-pinterest js-social-action-tracked js-btn-pinterest" data-position="Leftrail" data-service="Pinterest" data-action="Pin">
</div>
<a href="http://twitter.com/share?text=Watch%20the%20Walls%20Shimmer%20at%20Iran%27s%20Emerald%20Mosque%20@atlasobscura&amp;count=none&amp;url=http://www.atlasobscura.com/articles/watch-the-walls-shimmer-at-irans-emerald-mosque" class="icon-twitter btn-icon social-siderail-btn siderail-btn-twitter js-social-action-tracked" target="_blank" data-position="Leftrail" data-service="Twitter" data-action="Share"></a>
<a href="https://www.reddit.com/submit?url=http%3A%2F%2Fwww.atlasobscura.com%2Farticles%2Fwatch-the-walls-shimmer-at-irans-emerald-mosque" target="_blank" class="social-siderail-btn siderail-btn-reddit btn-reddit btn-icon icon-reddit js-social-action-tracked " data-position="Leftrail" data-service="reddit" data-action="Share"></a>
<a href="" class="icon-envelope btn-icon btn-email social-siderail-btn js-btn-email-share js-social-action-tracked siderail-btn-email" data-position="Leftrail" data-service="Email" data-action="Send" data-toggle="modal" data-target="#desktop-share-by-email-modal"></a>
</div>
<aside class="hidden-xs hidden-sm">
<div id="desktop-share-by-email-modal" class="modal" role="dialog">
<div class="modal-dialog">
<div class="modal-content">
<div class="modal-wrap">
<div class="row modal-bg">
<span class="modal-icon-bg icon-atlas-icon"></span>
<div class="modal-body email-share-modal-body col-md-12">
<span class="icon-modal-close modal-close" data-dismiss="modal"></span>
<div id="js-email-share-thanks" class="form-complete-notice"></div>
<form class="js-email-share-form" id="new_share" action="/articles/watch-the-walls-shimmer-at-irans-emerald-mosque/shares" accept-charset="UTF-8" data-remote="true" method="post"><input name="utf8" type="hidden" value="&#x2713;"/>
<h4 class="title-lg modal-title">Email This Article</h4>
<span id="js-email-this-error" class="error"></span>
<div>
<fieldset class="modal-fieldset">
<div class="cta-lg validate-message"></div>
<label class="cta-lg modal-label">From</label>
<input class="email-input col-md-12" placeholder="your email" required="required" type="email" name="share[from_email]" id="share_from_email"/>
</fieldset>
<fieldset class="modal-fieldset">
<div class="cta-lg validate-message"></div>
<label class="cta-lg modal-label">To</label>
<input class="col-md-12" placeholder="recipient email(s)" required="required" type="text" name="share[to_email]" id="share_to_email"/>
</fieldset>
<div class="caption email-share-caption">Please separate multiple addresses with commas. We won't share addresses with third parties.</div>
<fieldset class="modal-fieldset email-checkbox-fieldset">
<input name="share[subscribe_general]" type="hidden" value="0"/><input class="email-signup-checkbox hidden-md hidden-lg" type="checkbox" value="1" name="share[subscribe_general]" id="share_subscribe_general"/>
<label for="share_subscribe_general" class="email-signup-checkdisplay js-email-signup-checkdisplay hidden-sm hidden-xs"></label>
<div class="email-signup-label-pair">
<label class="modal-label email-signup-sublabel">Subscribe me to the</label>
<label class="modal-label cta-lg">Atlas Obscura Newsletter</label>
</div>
</fieldset>
<input type="submit" name="commit" value="Send" class="btn btn-stretch btn-submit"/>
</form> </div>
</div>
</div>
</div>
</div>
</div>
</div>
</aside>
<script type="text/javascript">
  displayFbCount('http://www.atlasobscura.com/articles/watch-the-walls-shimmer-at-irans-emerald-mosque', '.js-facebook-count');
</script>
</div>
</div>
<div class="content-body col-md-7">
<section id="article-body" class="item-body article--body">
<div class="hidden" id="newsletter-email-ask">
<div class="container-fluid border-container">
<div class="heading row">
<div class="col-xs col-xs-offset-1">
<h4>Enjoying This Story?</h4>
</div>
</div>
<div class="copy-container desktop">
<p>
Get our latest, delivered straight to your inbox by <a href="">subscribing to our newsletter</a>.
</p>
</div>
<div class="copy-container tablet">
<p>
<a href="">Subscribe to our newsletter</a> and get our latest, sent right to your inbox.
</p>
</div>
<div class="input-container">
<form class="js-email-ask-form" action="/email_lists/signup" accept-charset="UTF-8" data-remote="true" method="post"><input name="utf8" type="hidden" value="&#x2713;"/>
<input name="subscribe_general" type="hidden" value="true">
<input type="hidden" name="source" value="article-email-ask"/>
<div class="email-quick-signup-wrap">
<input type="email" name="email" id="email" placeholder="Your Email Address" class="js-article-email-ask-removable" required="required"/>
<button name="button" type="submit" class="btn btn-default js-article-email-ask-removable">Subscribe</button>
<div id="js-article-email-ask-thanks" class="subscribe-thanks">
Thanks for subscribing!
</div>
</div>
</form> </div>
</div>
</div>
<div class="hidden related-articles-interrupt" id="js-related-articles-interrupt">
<div class="container-fluid border-container">
<div class="heading row">
<div class="col-xs col-xs-offset-1">
<h4>Related Stories</h4>
</div>
</div>
<div class="copy-container">
<a class="recirc-item" href="watch-these-joyous-strangers-in-london-roll-a-massive-snowball-down-a-hill">Watch These Joyous Strangers in London Roll a Massive Snowball Down a Hill</a>
<a class="recirc-item" href="watch-a-time-lapse-of-a-museum-preparator-uncovering-fossil-specimens">How Museum Preparators Uncover Fossil Specimens </a>
<a class="recirc-item" href="listen-to-the-low-earthly-hum-of-a-candle-pipe-organ">Listen to the Low Earthly Hum of a Candle Pipe Organ </a>
</div>
</div>
</div>
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html><body>
<p><iframe src="https://www.youtube.com/embed/b9IFK8i0iSM?rel=0" width="640" height="360" frameborder="0" allowfullscreen=""></iframe></p>
<p class="item-body-text-graf">The surfaces of <a href="/places/shah-cheragh">Shah Cheragh</a>, a mosque in the Iranian city of Shiraz, glisten and shimmer as you walk by. Mosaics made of mirror shards and tiles cover each wall. Glittering chandeliers hang from the ceilings and spots of light dance in the domes. As the above video by Great Big Story shows, being inside is like inhabiting a disco ball.</p>
<p class="item-body-text-graf">Shah Cheragh, also known as the Emerald Mosque and the Shrine to the King of the Light, was originally built in the 1100s as a funerary monument to Ahmad and Muhammad, brothers who took refuge in Shiraz during the 10th-century persecution of Shia Muslims. Many additions and renovations have taken place over the centuries. Shah Cheragh is now the third most holy Shia shrine in Iran, and draws a substantial crowd for Friday night prayers. It&#8217;s not unusual to see worshippers kissing the mirrored walls post-prayer.</p>
<p class="item-body-text-graf"><em>Every day we track down a Video Wonder: an audiovisual offering that delights, inspires, and entertains. Have you encountered a video we should feature? Email </em><a href="/cdn-cgi/l/email-protection#d7b2bbbbb697b6a3bbb6a4b8b5a4b4a2a5b6f9b4b8ba"><em><span class="__cf_email__" data-cfemail="ff9a93939ebf9e8b939e8c909d8c9c8a8d9ed19c9092">[email&#160;protected]</span><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script></em></a></p>
<script>/* <![CDATA[ */(function(d,s,a,i,j,r,l,m,t){try{l=d.getElementsByTagName('a');t=d.createElement('textarea');for(i=0;l.length-i;i++){try{a=l[i].href;s=a.indexOf('/cdn-cgi/l/email-protection');m=a.length;if(a&&s>-1&&m>28){j=28+s;s='';if(j<m){r='0x'+a.substr(j,2)|0;for(j+=2;j<m&&a.charAt(j)!='X';j+=2)s+='%'+('0'+('0x'+a.substr(j,2)^r).toString(16)).slice(-2);j++;s=decodeURIComponent(s)+a.substr(j,m-j)}t.innerHTML=s.replace(/</g,'&lt;').replace(/>/g,'&gt;');l[i].href='mailto:'+t.value}}catch(e){}}}catch(e){}})(document);/* ]]> */</script></body></html>
</section>
<div class="row item-end-row">
<div class="item-tags col-md-12 col-md-12-nested col-md-pull-1 col-md-pull-1-nested">
<a href="/categories/mosques">#mosques</a><a href="/categories/islam">#islam</a><a href="/categories/video-wonders">#video wonders</a><a href="/categories/video">#video</a>
</div>
</div>
<div class="row hidden-xs hidden-sm">
<div class="col-md-12">
<div class="item-social-row">
<a href="" class="icon-facebook btn-facebook btn btn-icon js-share-button-facebook js-social-action-tracked btn-social-row col-md-4" data-position="TextBottom" data-service="Facebook" data-action="Share"></a>
<a href="http://twitter.com/share?text=Watch%20the%20Walls%20Shimmer%20at%20Iran%27s%20Emerald%20Mosque%20@atlasobscura&amp;count=none&amp;url=http://www.atlasobscura.com/articles/watch-the-walls-shimmer-at-irans-emerald-mosque" class="icon-twitter btn-twitter btn btn-icon js-social-action-tracked btn-social-row col-md-4" target="_blank" data-position="TextBottom" data-service="Twitter" data-action="Share"></a>
<a href="https://www.reddit.com/submit?url=http%3A%2F%2Fwww.atlasobscura.com%2Farticles%2Fwatch-the-walls-shimmer-at-irans-emerald-mosque" target="_blank" class="btn-reddit btn btn-icon icon-reddit js-social-action-tracked btn-social-row col-md-4 " data-position="TextBottom" data-service="reddit" data-action="Share"></a>
<a href="" class="icon-envelope btn btn-icon btn-email js-btn-email-share js-social-action-tracked btn-social-row col-md-4" data-position="TextBottom" data-service="Email" data-action="Send" data-toggle="modal" data-target="#desktop-share-by-email-modal"></a>
</div>
 
 
</div>
</div>
<div class="row next-article-recirc next-article-recirc-a">
<div class="col-md-12">
<hr>
<h2 class="detail-sm read-next">Read Next</h2>
<a href=/articles/the-bear-who-fought-for-the-polish-army>
<h3 class="title-underline">
<span class="next-recirc-article-title">
The Lovable Syrian Brown Bear Who Fought For His (Adoptive) Country</h3>
</span>
<span class="icon-arrow-right"></span>
</a>
<hr>
</div>
</div>
</div>
<div class="hidden-md hidden-lg m-social-adhesive-wrap">
<div id="js-item-social-adhesive" class="item-social-adhesive">
<div id="js-item-adhesive-btns">
<a href="" class="col-xs-3 btn btn-adhesive btn-facebook btn-icon js-share-button-facebook js-social-action-tracked" data-position="Bottom-Sticky-mobile" data-service="Facebook" data-action="Share">
<i class="icon-facebook"></i>
</a>
<div class="col-xs-3 btn btn-adhesive btn-pinterest btn-icon js-social-action-tracked js-btn-pinterest" data-position="Bottom-Sticky-mobile" data-service="Pinterest" data-action="Pin">
<i class="icon-pinterest"></i>
</div>
<a href="http://twitter.com/share?text=Watch%20the%20Walls%20Shimmer%20at%20Iran%27s%20Emerald%20Mosque%3A%20@atlasobscura&amp;count=none&amp;url=http://www.atlasobscura.com/articles/watch-the-walls-shimmer-at-irans-emerald-mosque" class="col-xs-3 btn btn-adhesive btn-twitter btn-icon js-social-action-tracked" target="_blank" data-position="Bottom-Sticky-mobile" data-service="Twitter" data-action="Share">
<i class="icon-twitter"></i>
</a>
<a href="https://www.reddit.com/submit?url=http%3A%2F%2Fwww.atlasobscura.com%2Farticles%2Fwatch-the-walls-shimmer-at-irans-emerald-mosque" target="_blank" class="col-xs-3 btn btn-adhesive btn-reddit btn-icon icon-reddit js-social-action-tracked" data-position="Bottom-Sticky-mobile" data-service="reddit" data-action="Share"></a>
<a href="/cdn-cgi/l/email-protection#9ca3efe9fef6f9ffe8a1cbfde8fff4bce8f4f9bccbfdf0f0efbccff4f5f1f1f9eebcfde8bcd5eefdf2babfafa5a7efbcd9f1f9eefdf0f8bcd1f3efede9f9bafef3f8e5a1d8f5effff3eaf9eef9f8bcf3f2bcdde8f0fdefbcd3feefffe9eefda6bcf4e8e8eca6b3b3ebebebb2fde8f0fdeff3feefffe9eefdb2fff3f1b3fdeee8f5fff0f9efb3ebfde8fff4b1e8f4f9b1ebfdf0f0efb1eff4f5f1f1f9eeb1fde8b1f5eefdf2efb1f9f1f9eefdf0f8b1f1f3efede9f9" class="col-xs-3 btn btn-adhesive btn-email btn-icon js-social-action-tracked" data-position="Bottom-Sticky-mobile" data-service="Email" data-action="Send">
<i class="icon-envelope"></i>
</a>
</div>
</div>
</div>
<div class="content-siderail col-md-4">
<div class="siderail-ad">
<div class="  ad-background">
 
<div id='div-gpt-ad-1438011102027-1' class='ad-wrapper'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1438011102027-1'); });
</script>
</div>
</div>
</div>
<aside id="sidebar-recent" class="aside-recirc-module related-articles-module">
<h5 class="aside-recirc-header">Recent Stories</h5>
<div class="aside-recirc-items">
<a class="aside-recirc-item" href="/articles/couple-accused-of-using-a-massive-manure-pile-to-annoy-their-neighbors-during-a-long-feud">
<img alt="" data-width="940" data-height="705" width="372" height="248" src="//assets.atlasobscura.com/media/W1siZiIsInVwbG9hZHMvYXNzZXRzL2U4ZjE3ZGE4MDc3NDNjZjYyY19DM1FuTnRQV2NBRUg3M3MuanBnIl0sWyJwIiwiY29udmVydCIsIi1xdWFsaXR5IDkxIC1hdXRvLW9yaWVudCJdLFsicCIsInRodW1iIiwiMzcyeDI0OCMiXV0/C3QnNtPWcAEH73s.jpg"/>
<h3 class="title-sm recirc-item-title"><span class="title-underline">Couple Accused of Using a Massive Manure Pile to Annoy Their Neighbors</span></h3>
<div class="subtitle-sm recirc-item-subtitle">A judge awarded the victims $15,000.</div>
<div class="detail-sm article-card-detail article-card-date">
January 31, 2017
</div>
</a>
<a class="aside-recirc-item" href="/articles/what-happens-when-80-falcons-fly-coach">
<h3 class="title-sm recirc-item-title"><span class="title-underline">What Happens When 80 Falcons Fly Coach</span></h3>
<div class="subtitle-sm recirc-item-subtitle">They were probably on their way to a hunting trip.</div>
<div class="detail-sm article-card-detail article-card-date">
January 31, 2017
</div>
</a>
<a class="aside-recirc-item" href="/articles/found-melted-uranium-rods-lost-at-fukushima">
<h3 class="title-sm recirc-item-title"><span class="title-underline">Found: Melted Uranium Rods, Lost at Fukushima</span></h3>
<div class="subtitle-sm recirc-item-subtitle">Six years after the disaster, Tepco may have found its lost nuclear debris.</div>
<div class="detail-sm article-card-detail article-card-date">
January 31, 2017
</div>
</a>
</div>
</aside>
<aside id="places-near-you-aside" class="aside-recirc-module nearby-places-articles-module">
<h5 class="aside-recirc-header">Places Near You</h5>
<div class="aside-recirc-items">
</div>
</aside>
</div>
</div>
</div>
</article>
<div class="recirc-footer-wrap">
<div id=js-footer-related-articles class="recirc-footer recirc-footer-articles hidden-date">
<div class="container">
<div class="row">
<div class="col-md-offset-1 col-md-1">
<h5 class="section-title section-title-articles">Related Stories</h5>
</div>
</div>
<div class="row">
<div class="footer-card-container">
<a class="content-card article-card" href="/articles/watch-a-net-gun-capture-a-thief-in-1969">
<img data-src="//assets.atlasobscura.com/media/W1siZiIsInVwbG9hZHMvYXNzZXRzLzgzYTliMjYzYzUyMWE3OThlMF9TY3JlZW4gU2hvdCAyMDE3LTAxLTI0IGF0IDEwLjAzLjE2IFBNIDEucG5nIl0sWyJwIiwiY29udmVydCIsIi1xdWFsaXR5IDkxIC1hdXRvLW9yaWVudCJdLFsicCIsInRodW1iIiwiMzcyeDI0OCMiXV0/Screen%20Shot%202017-01-24%20at%2010.03.16%20PM%201.png" title="In 1969, One Inventor Tried to Sell Police a &#39;Net Gun&#39; for Catching Robbers " alt="In 1969, One Inventor Tried to Sell Police a &#39;Net Gun&#39; for Catching Robbers " data-width="1920" data-height="1080" class="lazy img-responsive content-card-img" src="//assets.atlasobscura.com/assets/blank-11b9c95a68e295dddd0ea924647536578ce285b2c8469a223c01df1ff3166af1.png"/>
<div class="content-card-text">
<div class="detail-sm article-card-label">story</div>
<div class="detail-sm article-card-tag">villains week</div>
<h3 class="title-md content-card-title">
<span class="title-underline content-card-title-article js-title-content">In 1969, One Inventor Tried to Sell Police a &#39;Net Gun&#39; for Catching Robbers </span>
</h3>
<div class="subtitle content-card-subtitle content-card-subtitle-article js-subtitle-content">While effective, the invention never quite took off.</div>
<div class="detail-sm article-card-detail article-card-date">
January 26, 2017
</div>
</div>
</a>
</div>
<div class="footer-card-container">
<a class="content-card article-card" href="/articles/watch-a-hong-kong-villainhitter-beat-evil-foes-with-a-shoe">
<img data-src="//assets.atlasobscura.com/media/W1siZiIsInVwbG9hZHMvYXNzZXRzLzdmY2IxYmY2MjBkOWUyOThmOF92aWxsYWluIGhpdHRpbmcgMy5qcGciXSxbInAiLCJjb252ZXJ0IiwiLXF1YWxpdHkgOTEgLWF1dG8tb3JpZW50Il0sWyJwIiwidGh1bWIiLCIzNzJ4MjQ4IyJdXQ/villain%20hitting%203.jpg" title="Watch a Hong Kong &#39;Villain-Hitter&#39; Beat Away Foes With a Shoe" alt="Watch a Hong Kong &#39;Villain-Hitter&#39; Beat Away Foes With a Shoe" data-width="1300" data-height="866" class="lazy img-responsive content-card-img" src="//assets.atlasobscura.com/assets/blank-11b9c95a68e295dddd0ea924647536578ce285b2c8469a223c01df1ff3166af1.png"/>
<div class="content-card-text">
<div class="detail-sm article-card-label">story</div>
<div class="detail-sm article-card-tag">villains week</div>
<h3 class="title-md content-card-title">
<span class="title-underline content-card-title-article js-title-content">Watch a Hong Kong &#39;Villain-Hitter&#39; Beat Away Foes With a Shoe</span>
</h3>
<div class="subtitle content-card-subtitle content-card-subtitle-article js-subtitle-content">The centuries-old ritual started as a way to drive away evil spirits. </div>
<div class="detail-sm article-card-detail article-card-date">
January 25, 2017
</div>
</div>
</a>
</div>
<div class="footer-card-container">
<a class="content-card article-card" href="/articles/watch-a-man-turn-a-lump-of-hot-sugar-into-a-bunny">
<img data-src="//assets.atlasobscura.com/media/W1siZiIsInVwbG9hZHMvYXNzZXRzLzhjNmZhNDU0MzRkYThkMmMwYV9ibG93bi1nbGFzcy5wbmciXSxbInAiLCJjb252ZXJ0IiwiLXF1YWxpdHkgOTEgLWF1dG8tb3JpZW50Il0sWyJwIiwidGh1bWIiLCIzNzJ4MjQ4IyJdXQ/blown-glass.png" title="Watch a Man Turn a Lump of Hot Sugar Into a Bunny" alt="Watch a Man Turn a Lump of Hot Sugar Into a Bunny" data-width="1257" data-height="786" class="lazy img-responsive content-card-img" src="//assets.atlasobscura.com/assets/blank-11b9c95a68e295dddd0ea924647536578ce285b2c8469a223c01df1ff3166af1.png"/>
<div class="content-card-text">
<div class="detail-sm article-card-label">story</div>
<div class="detail-sm article-card-tag">candy</div>
<h3 class="title-md content-card-title">
<span class="title-underline content-card-title-article js-title-content">Watch a Man Turn a Lump of Hot Sugar Into a Bunny</span>
</h3>
<div class="subtitle content-card-subtitle content-card-subtitle-article js-subtitle-content">Sugar blowing is a pretty sweet art.</div>
<div class="detail-sm article-card-detail article-card-date">
January 24, 2017
</div>
</div>
</a>
</div>
<div class="footer-card-container">
<a class="content-card article-card" href="/articles/take-a-tour-of-al-capones-killer-cadillac-that-once-terrorized-chicago-streets">
<img data-src="//assets.atlasobscura.com/media/W1siZiIsInVwbG9hZHMvYXNzZXRzLzEzZjU3MzQyZDBiZDc3ZjlmNl9raWxsZXIgY2FyLmpwZyJdLFsicCIsImNvbnZlcnQiLCItcXVhbGl0eSA5MSAtYXV0by1vcmllbnQiXSxbInAiLCJ0aHVtYiIsIjM3MngyNDgjIl1d/killer%20car.jpg" title="A Tour of Al Capone&#39;s &#39;Killer&#39; Cadillac, Which Once Terrorized Chicago Streets" alt="A Tour of Al Capone&#39;s &#39;Killer&#39; Cadillac, Which Once Terrorized Chicago Streets" data-width="1920" data-height="1080" class="lazy img-responsive content-card-img" src="//assets.atlasobscura.com/assets/blank-11b9c95a68e295dddd0ea924647536578ce285b2c8469a223c01df1ff3166af1.png"/>
<div class="content-card-text">
<div class="detail-sm article-card-label">story</div>
<div class="detail-sm article-card-tag">gangsters</div>
<h3 class="title-md content-card-title">
<span class="title-underline content-card-title-article js-title-content">A Tour of Al Capone&#39;s &#39;Killer&#39; Cadillac, Which Once Terrorized Chicago Streets</span>
</h3>
<div class="subtitle content-card-subtitle content-card-subtitle-article js-subtitle-content">It featured bullet-proof glass and a police siren.</div>
<div class="detail-sm article-card-detail article-card-date">
January 23, 2017
</div>
</div>
</a>
</div>
</div>
</div>
</div>
<div class="recirc-footer recirc-footer-third-party">
<div class="container">
<div class="row">
<div class="col-md-offset-1 col-md-1">
<h5 class="section-title section-title-third-party">From Elsewhere</h5>
</div>
</div>
<div class="row">
<div id="zergnet-widget-30991"></div>
</div>
</div>
</div>
<script language="javascript" type="text/javascript">
  (function() {
    var zergnet = document.createElement('script');
    zergnet.type = 'text/javascript'; zergnet.async = true;
    zergnet.src = 'http://www.zergnet.com/zerg.js?id=30991';
    var znscr = document.getElementsByTagName('script')[0];
    znscr.parentNode.insertBefore(zergnet, znscr);
  })();
 </script>
<div class="footer-reflow">
 
<aside id="sidebar-recent" class="aside-recirc-module related-articles-module">
<h5 class="aside-recirc-header">Recent Stories</h5>
<div class="aside-recirc-items">
<a class="aside-recirc-item" href="/articles/found-melted-uranium-rods-lost-at-fukushima">
<img title="A shot of Fukushima from 2011." alt="A shot of Fukushima from 2011." data-width="932" data-height="681" width="372" height="248" src="//assets.atlasobscura.com/media/W1siZiIsInVwbG9hZHMvYXNzZXRzLzM2MWJkYTIzNzA4MTNhMWU5MF81NTI5MDM4MTM1X2YwNDUzYzdlNDlfYi5qcGciXSxbInAiLCJjb252ZXJ0IiwiLXF1YWxpdHkgOTEgLWF1dG8tb3JpZW50Il0sWyJwIiwidGh1bWIiLCIzNzJ4MjQ4IyJdXQ/5529038135_f0453c7e49_b.jpg"/>
<h3 class="title-sm recirc-item-title"><span class="title-underline">Found: Melted Uranium Rods, Lost at Fukushima</span></h3>
<div class="subtitle-sm recirc-item-subtitle">Six years after the disaster, Tepco may have found its lost nuclear debris.</div>
<div class="detail-sm article-card-detail article-card-date">
January 31, 2017
</div>
</a>
<a class="aside-recirc-item" href="/articles/the-singer-who-topped-charts-by-embracing-his-stutter">
<h3 class="title-sm recirc-item-title"><span class="title-underline">The Singer Who Topped Charts by Embracing His Stutter</span></h3>
<div class="subtitle-sm recirc-item-subtitle">Scatman John was more than a one-hit wonder.</div>
<div class="detail-sm article-card-detail article-card-date">
January 31, 2017
</div>
</a>
<a class="aside-recirc-item" href="/articles/the-stunning-early-infographics-and-maps-of-the-1800s">
<h3 class="title-sm recirc-item-title"><span class="title-underline">The Stunning Early Infographics and Maps of the 1800s </span></h3>
<div class="subtitle-sm recirc-item-subtitle">Educational diagrams of scientific discoveries, from the moon&#39;s surface to the longest rivers. </div>
<div class="detail-sm article-card-detail article-card-date">
January 30, 2017
</div>
</a>
</div>
</aside>
</div>
<div class="hidden-md hidden-lg">
<div class="ad-spacer" style="background-color: rgba(0, 82, 125, 0.1); padding:0 20px">
<div class="border" style="border-top: 1px solid #ccc;"></div>
</div>
<div class="ad-background" style="text-align: center; padding: 35px 0 35px;" styleX="text-align: center; padding: 35px 0 35px; border-top: 1px solid #ddd; border-bottom: 1px solid #ddd">
 
<div id='div-gpt-ad-1438011102027-11' class='ad-wrapper'>
<script type='text/javascript'>
  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1438011102027-11'); });
</script>
</div>
</div>
</div>
<div class="footer-reflow">
<aside id="reflow-places-near-you-aside" class="aside-recirc-module nearby-places-articles-module">
<h5 class="aside-recirc-header">Places Near You</h5>
<div class="aside-recirc-items">
</div>
</aside>
</div>
</div>
 
<script type="text/javascript" async defer data-pin-color="gray" data-pin-hover="true" data-pin-height="28" src="//assets.pinterest.com/js/pinit.js"></script>
<script type="text/javascript">
  pinterestAllContent();
  googletag.cmd.push(function() {
    googletag.pubads().addEventListener('slotRenderEnded', function(event) {
      listenForElementsIn( 'body', 'iframe', noPinWithin, '.ad-wrapper' );
    });
  });
</script>
<script async defer src="//platform.instagram.com/en_US/embeds.js"></script>
<script async src="https://secure.assets.tumblr.com/post.js"></script>
<script type="text/javascript">
  $(".article-image").each(function(){
    $(this).attr("onload", stablePinOn(this));
  });
  noPinWithin('.content-siderail');
  noPinWithin('.recirc-footer-wrap');
</script>
<script type="text/javascript">
  if( isIE() ){
    $("#article-body .article-image").removeAttr("width");
  }
</script>
<script type="text/javascript" charset="utf-8">
$(function () {
  var ArticleBodyState = {};
  var $articleContent = $('.content-body #article-body').children();
  placeTeads($articleContent);


  if (!isSubscribed()) {
    placeInterruptContent($articleContent, hasImageContent, placeArticleEmailAsk);
  } else {
    placeInterruptContent($articleContent, hasImageContent, placeRelatedArticlesInterrupt);
  }


  function placeInterruptContent($content, nodeCheckFunction, placingFunction, limit) {
    var limit = (typeof limit !== 'undefined') ?  limit : 7;

    var n = 0;
    var contentWasPlaced = false;

    $content.each(function (index, p) {
      // nodeCheckFunction must take a node &
      // return true/false about its content
      if ( nodeCheckFunction( $(p) ) ) { return; }
      n++;

      if (n >= limit) {
        if ( nodeCheckFunction($(p).next()) ) { return; }

        placingFunction(p);
        contentWasPlaced = true;
        return false;
      }
    });

    if (!contentWasPlaced) {
      placingFunction($articleContent.last());
    }
  }

  function placeTeads($content) {

    var videoDfp = "<!-- /9729793/1x1_video_btf -->\n<div id=\"video-body-ad\" style=\"line-height: 0; min-height: 1px; position: relative; bottom: 14px;\">\n  <div id=\'div-gpt-ad-1438011102027-9\' class=\'ad-wrapper\' >\n  <script type=\'text/javascript\'>\n  googletag.cmd.push(function() { googletag.display(\'div-gpt-ad-1438011102027-9\'); });\n  <\/script>\n  <\/div>\n<\/div>\n\n";
    var n = 0;
    var limit = 5;

    $content.each(function (index, p) {
      if (isNotBodyText(p)) { return; }

      n++;
      if (n >= limit) {
        if (hasImageContent($(p).next())) { return; }
        $(p).after(videoDfp);
        return false;
      }
    });
  }

  function placeArticleEmailAsk(p) {
    ArticleBodyState.emailAsk = $('#newsletter-email-ask').detach();
    ArticleBodyState.emailAsk.insertAfter(p);
    ArticleBodyState.emailAsk.removeClass("hidden");
    attachEmailAskListeners();
  }

  function placeRelatedArticlesInterrupt(p) {
    if ($('#js-related-articles-interrupt').length > 0) {
      ArticleBodyState.relatedArticles = $('#js-related-articles-interrupt').detach();
      ArticleBodyState.relatedArticles.insertAfter(p);
      ArticleBodyState.relatedArticles.removeClass('hidden');
    }
  }

  function attachEmailAskListeners() {
    ArticleBodyState.emailAsk.on('click', 'a', function (e) {
      e.preventDefault();
    });

    ArticleBodyState.emailAsk.on('click', function (e) {
      e.preventDefault();
      ArticleBodyState.emailAsk.find('.input-container')
        .slideToggle(200);
    });

    ArticleBodyState.emailAsk.find('#email').on('click', function (e) {
      e.stopPropagation();
    });

    ArticleBodyState.emailAsk.find('button').on('click', function (e) {
      e.stopPropagation();
    });
  }

  function placeInBodyAd(p) {
    var bodyWithNow = $("body.articles")[0].offsetWidth;
    ArticleBodyState.featureAdMarkup = "<div class='ad-background-intra-body'>" +
      "<!-- /9729793/content_body_responsive -->\n<div id=\'div-gpt-ad-1438011102027-13\' class=\'ad-wrapper\'><\/div>\n<script type=\'text/javascript\'>\n  googletag.cmd.push(function() { googletag.display(\'div-gpt-ad-1438011102027-13\'); });\n<\/script>\n" +
      "</div>";
    Content = $articleContent;
    $(p).after( ArticleBodyState.featureAdMarkup );
  }
});
</script>
<script type="text/javascript">
  var _ain = {
      id: "1426",
      url: "http://www.atlasobscura.com/articles/watch-the-walls-shimmer-at-irans-emerald-mosque",
      postid: "article-7867",
      maincontent: "#article-body",
      title: "Watch the Walls Shimmer at Iran&#39;s Emerald Mosque",
      pubdate: "2017-01-30 17:43:00 UTC",
      authors: "Ella Morton",
      sections: "",
      tags: "islam, mosques, video wonders, video",
      comments: ""
  };
  (function (d, s) {
  var sf = d.createElement(s); sf.type = 'text/javascript'; sf.async = true;
  sf.src = (('https:' == d.location.protocol) ? 'https://d7d3cf2e81d293050033-3dfc0615b0fd7b49143049256703bfce.ssl.cf1.rackcdn.com' : 'http://t.contentinsights.com')+'/stf.js';
  var t = d.getElementsByTagName(s)[0]; t.parentNode.insertBefore(sf, t);
  })(document, 'script');
</script>
<footer class="page-footer">
<div class="footer-z-cover"></div>
<div class="container">
<div class="row">
<div class="footer-links col-md-3">
<section>
<h3 class="heading-sm footer-links-heading js-footer-links-heading">
The Atlas <i class="icon-arrow-down footer-expand-arrow visible-sm visible-xs"></i>
</h3>
<div class="is-slider-hidden-m">
<ul class="links-column">
<li><a href="/places">Recently Added</a></li>
<li><a href="/places?sort=likes_count">Most Popular</a></li>
<li><a href="/random">Random</a></li>
<li><a href="/curious-facts">Curious Facts</a></li>
<li><a class="js-user-required" href="/places/new">Add a Place</a></li>
</ul>
</div>
</section>
<div>
<section>
<h3 class="heading-sm footer-links-heading js-footer-links-heading">
Events <i class="icon-arrow-down footer-expand-arrow visible-sm visible-xs"></i>
</h3>
<div class="is-slider-hidden-m">
<ul class="links-column">
<li><a href="/events">Upcoming Events</a></li>
<li><a href="/unusual-trips">Upcoming Trips</a></li>
</ul>
</div>
</section>
</div>
</div>
<div class="footer-links col-md-3">
<section>
<h3 class="heading-sm footer-links-heading js-footer-links-heading">
Stories <i class="icon-arrow-down footer-expand-arrow visible-sm visible-xs"></i>
</h3>
<div class="is-slider-hidden-m">
<ul class="links-column">
<li><a href="/articles?sort=columns">Columns</a></li>
<li><a href="/articles?sort=features">Features</a></li>
<li><a href="/articles?sort=interactive">Interactive</a></li>
<li><a href="/articles?sort=news">News</a></li>
<li><a href="/articles?sort=video">Video</a></li>
<li><a href="/articles?sort=visual">Visual</a></li>
</ul>
</div>
</section>
</div>
<div class="footer-links col-md-3">
<section>
<h3 class="heading-sm footer-links-heading js-footer-links-heading">
Company <i class="icon-arrow-down footer-expand-arrow visible-sm visible-xs"></i>
</h3>
<div class="is-slider-hidden-m">
<ul class="links-column">
<li><a href="/about-us">About</a></li>
<li class="hidden-md hidden-lg"><a href="javascript:void( window.open(&#39;http://form.jotformpro.com/form/22734371641956&#39;, &#39;blank&#39;,&#39;scrollbars=yes,toolbar=no,width=750,height=500&#39;))" target="_blank">Contact Us</a></li>
<li><a href="/faq">FAQ</a></li>
<li><a href="/work-with-us">Work With Us</a></li>
<li><a href="/cdn-cgi/l/email-protection#442520370425302825372b2637273136256a272b29">Advertising</a></li>
<li><a href="/privacy">Privacy Policy</a></li>
<li><a href="/terms">Terms of Use</a></li>
</ul>
</div>
</section>
</div>
<div class="footer-social col-md-3">
<section class="subscribe-sm footer-subscribe">
<span>Subscribe to the Atlas Obscura Newsletter and get our latest, delivered straight to your inbox.</span>
<form class="js-email-ask-form" action="/email_lists/signup" accept-charset="UTF-8" data-remote="true" method="post"><input name="utf8" type="hidden" value="&#x2713;"/>
<input type="hidden" name="source" id="source" value="footer-email-ask"/>
<input type="hidden" name="subscribe_general" id="subscribe_general" value="true"/>
<input type="email" name="email" id="email" placeholder="Your Email" class="js-footer-email-ask-removable"/>
<input type="submit" name="commit" value="Subscribe" class="btn btn-secondary js-footer-email-ask-removable"/>
<div id="js-footer-email-ask-thanks" class="subscribe-thanks detail">Thanks for subscribing!</div>
</form>
<ul id="footer-social-list">
<li><a href="https://www.facebook.com/atlasobscura/" class="icon-facebook btn-icon footer-social-btn js-social-action-tracked" target="_blank" data-position="Footer" data-service="Facebook" data-action="Like"></a></li>
<li><a href="https://www.youtube.com/user/atlasobscura" class="icon-youtube btn-icon footer-social-btn js-social-action-tracked" target="_blank" data-position="Footer" data-service="Youtube" data-action="Follow"></a></li>
<li><a href="https://twitter.com/atlasobscura" class="icon-twitter btn-icon footer-social-btn js-social-action-tracked" target="_blank" data-position="Footer" data-service="Twitter" data-action="Follow"></a></li>
<li><a href="https://www.instagram.com/atlasobscura/" class="icon-instagram btn-icon footer-social-btn js-social-action-tracked" target="_blank" data-position="Footer" data-service="Instagram" data-action="Follow"></a></li>
<li><a href="https://www.pinterest.com/atlasobscura/" class="icon-pinterest btn-icon footer-social-btn js-social-action-tracked" target="_blank" data-position="Footer" data-service="Pinterest" data-action="Follow"></a></li>
<li><a href="/feeds/latest" class="icon-rss btn-icon footer-social-btn js-social-action-tracked" target="_blank" data-position="Footer" data-service="RSS" data-action="Follow"></a></li>
</ul>
</section>
</div>
</div>
<div class="row">
<div class="copyright col-md-6 hidden-sm hidden-xs">&copy; 2017 Atlas Obscura. All rights reserved.</div>
<div class="col-md-3 col-md-offset-3 footer-logo-wrap">
<a href="/" title="Atlas Obscura" class="footer-logo logo-link">
<i class="icon-atlas-icon"></i>
<i class="icon-atlas-logo"></i>
</a>
</div>
<div class="copyright hidden-md hidden-lg col-xs-12">&copy; 2017 Atlas Obscura. All rights reserved.</div>
</div>
</div>
</footer>
<a href="javascript:void( window.open('http://form.jotformpro.com/form/22734371641956', 'blank','scrollbars=yes,toolbar=no,width=700,height=500'))">
<button id="btn-site-feedback" class="btn btn-stretch">Issues with the site? <span class="static-underline">Please let us know.</span></button>
</a>
 
<div id="email-roadblock-topographic-modal" class="modal" role="dialog">
<div class="modal-dialog">
<div class="modal-content">
<div class="modal-wrap modal-wrap-topographic topographic modal-wrap-responsive">
<i class="icon-modal-close modal-close" data-dismiss="modal"></i>
<div class="row modal-bg roadblock-modal-content">
<div class="modal-body">
<div id="js-email-roadblock-topographic-modal-thanks" class="form-complete-notice"></div>
<form class="js-email-roadblock-form js-email-ask-form" action="/email_lists/signup" accept-charset="UTF-8" data-remote="true" method="post"><input name="utf8" type="hidden" value="&#x2713;"/>
<input type="hidden" name="subscribe_general" value="true"/>
<input type="hidden" name="source" value="email-roadblock-topographic-modal"/>
<h4 class="title-lg modal-title-roadblock">Escape the Beaten Path</h4>
<div class="subtitle-md">Subscribe to the Atlas Obscura Newsletter and get our latest, delivered straight to your inbox.</div>
<div id="js-email-roadblock-topographic-modal-error"></div>
<fieldset class="modal-fieldset">
<div class="cta-lg validate-message"></div>
<div class="email-submit-group-m">
<input type="email" name="email" id="email" class="col-md-12" required="required" placeholder="your email"/>
<button name="button" type="submit" class="btn btn-stretch btn-submit">
<i class="icon-envelope"></i><span class="hidden-sm hidden-xs">Subscribe</span>
</button> </div>
</fieldset>
<footer class="roadblock-footer">
<a href="" class="roadblock-dismiss-link cta-lg" data-dismiss="modal">No Thanks</a>
</footer>
</form> </div>
</div>
</div>
</div>
</div>
</div>
<div id="facebook-topographic-modal" class="modal" role="dialog">
<div class="modal-dialog">
<div class="modal-content">
<div class="modal-wrap modal-wrap-topographic topographic modal-wrap-responsive modal-wrap-fb">
<i class="icon-modal-close modal-close" data-dismiss="modal"></i>
<div class="row modal-bg roadblock-modal-content">
<div class="modal-body">
<div id="js-email-roadblock-topographic-modal-thanks" class="form-complete-notice"></div>
<form class="js-email-roadblock-form" action="/email_lists/signup" accept-charset="UTF-8" data-remote="true" method="post"><input name="utf8" type="hidden" value="&#x2713;"/>
<input type="hidden" name="subscribe_general" value="true"/>
<input type="hidden" name="source" value="email-roadblock-topographic-modal"/>
<h4 class="title-lg modal-title-roadblock" style="font-size: 38px;">We'd Like You to Like Us</h4>
<div class="subtitle-md">Like Atlas Obscura and get our latest and greatest stories in your Facebook feed.</div>
<fieldset class="modal-fieldset">
<div id="fb-modal-like-wrap"></div>
</fieldset>
<footer class="roadblock-footer">
<a href="" class="roadblock-dismiss-link cta-lg" data-dismiss="modal">No Thanks</a>
</footer>
</form> </div>
</div>
</div>
</div>
</div>
</div>
<div id="facebook-page-plugin" class="hidden-sm hidden-xs">
<i class="icon-modal-close js-close"></i>
<h3 class="title-sm">Like Us on Facebook</h3>
<div class="fb-page" data-href="https://www.facebook.com/atlasobscura" data-width="280" data-hide-cover="true" data-show-facepile="true" data-show-posts="false">
<div class="fb-xfbml-parse-ignore">
</div>
</div>
</div>
<div id="fixed-notice-m" class="notice js-notice">
<div class="table-container">
<i class="icon-info"></i>
<span class="notice-text-wrapper">
<span id="fixed-notice-m-text"></span>
</span>
<i class="icon-menu-close js-dismiss-notice"></i>
</div>
</div>
<script type="text/javascript" src="//s.skimresources.com/js/89027X1542228.skimlinks.js"></script>
 
<script>
      var _comscore = _comscore || [];
      _comscore.push({ c1: "2", c2: "17564338" });
      (function() {
        var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
        s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
        el.parentNode.insertBefore(s, el);
      })();
    </script>
<noscript>
<img src="http://b.scorecardresearch.com/p?c1=2&c2=17564338&cv=2.0&cj=1"/>
</noscript>
 
 
<script type="text/javascript">
    var _qevents = _qevents || [];

    (function() {
    var elem = document.createElement('script');
    elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
    elem.async = true;
    elem.type = "text/javascript";
    var scpt = document.getElementsByTagName('script')[0];
    scpt.parentNode.insertBefore(elem, scpt);
    })();
    </script>
<script>
    _qevents.push({
    qacct:"p-wCQ2x-2BzmYPY"
    });
    </script>
<noscript>
<div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-wCQ2x-2BzmYPY.gif" border="0" height="1" width="1" alt="Quantcast"/></div>
</noscript>
<script type="text/javascript">
        ga('set', 'dimension1', 'Guest');
      </script>
<script>/* <![CDATA[ */(function(d,s,a,i,j,r,l,m,t){try{l=d.getElementsByTagName('a');t=d.createElement('textarea');for(i=0;l.length-i;i++){try{a=l[i].href;s=a.indexOf('/cdn-cgi/l/email-protection');m=a.length;if(a&&s>-1&&m>28){j=28+s;s='';if(j<m){r='0x'+a.substr(j,2)|0;for(j+=2;j<m&&a.charAt(j)!='X';j+=2)s+='%'+('0'+('0x'+a.substr(j,2)^r).toString(16)).slice(-2);j++;s=decodeURIComponent(s)+a.substr(j,m-j)}t.innerHTML=s.replace(/</g,'&lt;').replace(/>/g,'&gt;');l[i].href='mailto:'+t.value}}catch(e){}}}catch(e){}})(document);/* ]]> */</script></body>
</html>
